ppo_eval_render.yaml 1.8 KB
Newer Older
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21
flatland-render-test:
    run: PPO
    env: flatland_sparse
    stop:
        training_iteration: 6
        # timesteps_total: 5000  # 1e7
    checkpoint_freq: 10
    checkpoint_at_end: True
    keep_checkpoints_num: 5
    checkpoint_score_attr: episode_reward_mean
    config:
        clip_rewards: True
        clip_param: 0.1
        vf_clip_param: 500.0
        entropy_coeff: 0.01
        # effective batch_size: train_batch_size * num_agents_in_each_environment [5, 10]
        # see https://github.com/ray-project/ray/issues/4628
        train_batch_size: 1000  # 5000
        rollout_fragment_length: 50  # 100
        sgd_minibatch_size: 100  # 500
        num_sgd_iter: 10
22
        num_workers: 1
23 24 25 26 27 28 29 30 31 32 33
        num_envs_per_worker: 1
        batch_mode: truncate_episodes
        observation_filter: NoFilter
        vf_share_layers: True
        vf_loss_coeff: 0.5
        num_gpus: 0

        env_config:
            observation: new_tree
            skip_no_choice_cells: True
            available_actions_obs: True
34
            # render: human
35 36
            # For saving videos in custom folder and to wandb.
            # By default if not specified folder is flatland
37
            # video_dir: small_tree_video
38 39 40 41 42 43
            observation_config:
                max_depth: 2
                shortest_path_max_depth: 30

            generator: sparse_rail_generator
            generator_config: small_v0
44
            eval_generator: test_render
45 46 47

            wandb:
                project: neurips2020-flatland-baselines
48
                entity: aicrowd
49 50 51 52 53 54 55 56
                tags: ["small_v0", "tree_obs"] # TODO should be set programmatically
                # monitor_gym: True # Wandb video doesn't seem to work

        model:
            fcnet_activation: relu
            fcnet_hiddens: [256, 256]
            vf_share_layers: True  # False